Вопрос по quagga FreeBSD

Статическая и динамическая, протоколы

Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 15:59

Добрый день!
Подскажите пожалуйста, должны ли маршруты из quagga попадать в kernel routes?
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 16:11

Да, должны. Вот пример маршрута к сети 1.9.0.0/16, внедренного кваггой в таблицу роутинга:
Код: Выделить всё
[bgp:~] route get 1.9.0.0
   route to: 1.9.0.0
destination: 1.9.0.0
       mask: 255.255.0.0
    gateway: X.X.X.X
  interface: vlan997
      flags: <UP,GATEWAY,DONE,PROTO1>
 recvpipe  sendpipe  ssthresh  rtt,msec    rttvar  hopcount      mtu     expire
       0         0         0         0         0         0      1500         0
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 16:24

Спасибо!
Тогда взгляните на bgpd.conf может в нем ошибка...

Код: Выделить всё
!
router bgp 51158
bgp router-id 2.2.2.3
bgp log-neighbor-changes
no synchronization
no auto-summary
!
network x.x.212.0/24
network x.x.213.0/24
network x.x.214.0/24
network x.x.215.0/24
!
neighbor 1.1.1.1 remote-as 20870
neighbor 1.1.1.1 description TTK
neighbor 1.1.1.1 update-source 1.1.1.2
neighbor 1.1.1.1 next-hop-self
neighbor 1.1.1.1 soft-reconfiguration inbound
neighbor 1.1.1.1 route-map TTK-in in
neighbor 1.1.1.17 route-map TTK-out out
!
neighbor 2.2.2.2 remote-as 12389
neighbor 2.2.2.2 description RTK
neighbor 2.2.2.2 update-source 2.2.2.3
neighbor 2.2.2.2 next-hop-self
neighbor 2.2.2.2 soft-reconfiguration inbound
neighbor 2.2.2.2 route-map RTK-in in
neighbor 2.2.2.2 route-map RTK-out out
!
neighbor 3.3.3.3 remote-as 12389
neighbor 3.3.3.3 description RTK-WORLD
neighbor 3.3.3.3 update-source 3.3.3.4
neighbor 3.3.3.3 next-hop-self
neighbor 3.3.3.3 ebgp-multihop 7
neighbor 3.3.3.3 soft-reconfiguration inbound
neighbor 3.3.3.3 route-map RTK-in in
neighbor 3.3.3.3 route-map RTK-out out
neighbor 3.3.3.3 prefix-list ALL out
!
ip prefix-list default description default route
ip prefix-list default seq 10 permit 0.0.0.0/0
!
ip prefix-list bogons description bogus nets
ip prefix-list bogons seq 15 permit 0.0.0.0/8 le 32
ip prefix-list bogons seq 20 permit 127.0.0.0/8 le 32
ip prefix-list bogons seq 30 permit 10.0.0.0/8 le 32
!ip prefix-list bogons seq 35 permit 172.16.0.0/12 le 32
ip prefix-list bogons seq 40 permit 192.168.0.0/16 le 32
ip prefix-list bogons seq 45 permit 169.254.0.0/16 le 32
ip prefix-list bogons seq 50 permit 224.0.0.0/4 le 32
ip prefix-list bogons seq 55 permit 240.0.0.0/4 le 32
!
ip prefix-list our-CIDR-blocks seq 5 permit x.x.212.0/22 le 32
!
ip prefix-list upstream-out seq 10 permit x.x.212.0/22
!
ip as-path access-list 1 permit _6451[2-9]_
ip as-path access-list 1 permit _645[2-9][0-9]_
ip as-path access-list 1 permit _64[6-9][0-9][0-9]_
ip as-path access-list 1 permit _65[0-9][0-9][0-9]_
!
route-map TTK-in deny 100
match as-path 1
!
route-map TTK-in deny 110
match ip address prefix-list bogons
!
route-map TTK-in deny 115
match ip address prefix-list default
!
!route-map TTK-in deny 120
!match ip address prefix-list our-CIDR-blocks
!
route-map TTK-in permit 200
set local-preference 100
!
route-map TTK-out permit 100
match ip address prefix-list upstream-out
!
route-map TTK-out deny 200
!
route-map RTK-in deny 100
match as-path 1
!
route-map RTK-in deny 110
match ip address prefix-list bogons
!
route-map RTK-in deny 115
match ip address prefix-list default
!
!route-map RTK-in deny 120
!match ip address prefix-list our-CIDR-blocks
!
route-map RTK-in permit 200
set local-preference 100
!
route-map RTK-out permit 100
match ip address prefix-list upstream-out
!
route-map RTK-out permit 200
set as-path prepend 51158
!
route-map RTK-out deny 300
!

При такой конфигурации трафик идет, если только прописан default в kernel routes.
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 16:27

Тогда взгляните на bgpd.conf может в нем ошибка...

А что "лечим-то"? :)
BGP-сессии подняты?
Нелишним будет вывод
Код: Выделить всё
sh ip bgp summary
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 16:30

lehisnoe писал(а):
Тогда взгляните на bgpd.conf может в нем ошибка...

А что "лечим-то"? :)


При такой конфигурации трафик идет, если только прописан default в kernel routes.
Quagga маршруты получает, их видно по sh ip route, а в kernel routes они не видны.
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 16:33

Какая ОСь на серванте?
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 16:38

> uname -a
FreeBSD 8.1-RELEASE FreeBSD 8.1-RELEASE #0: Mon Jul 19 02:36:49 UTC 2010 root@mason.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC amd64
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 16:45

Запость вывод
Код: Выделить всё
sh ip bgp summary
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 16:46

lehisnoe писал(а):Запость вывод
Код: Выделить всё
sh ip bgp summary

Код: Выделить всё
BGP router identifier 2.2.2.3, local AS number 51158
RIB entries 619938, using 57 MiB of memory
Peers 3, using 13 KiB of memory

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1     4 20870  475873   12055        0    0    0 01w1d08h   327795
2.2.2.2  4 12389   13258  498628        0    0    0 01w1d08h        6
3.3.3.3  4 12389 1338327   24111        0    0    0 4d17h41m   327253

Total number of neighbors 3
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 17:07

Сессии установлены, маршруты "приезжают" - уже хорошо.
А маршрутные карты пробовал убирать? Просто у нас нету еще ни одной квагги на 8.1...
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

След.

Вернуться в Маршрутизация / Routing

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0

cron