BGP TEST

Статическая и динамическая, протоколы

BGP TEST

Сообщение waxmax » 26 июн 2009, 14:21

Доброго всем пинга.
Пока физику не подняли с пиром, решил протестить BGP, повозиться с ним.

В распоряжении Cisco 7201
и FreeBSD на виртуалке.

Циска для меня, а фря как бы за пира настроил.
все поднял, сконфигурил, BGP state = Established и все такое.
(Отдельное спасибо Николаеву Дмитрию, за его статью ;) )

Но!
а вот теперь кое что странное!:
на циске пдаем команду sh ip bgp и смотрим получаем ли мы маршруты от соседа:
Код: Выделить всё
c7201#s ip bgp
BGP table version is 4, local router ID is 200.200.200.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.100.100.0/24  2.2.2.2           0             0 100 i


тоесть вроди получаеца, что все номально получаем инфу о сетке.
Но теперь
на freebsd пдаем команду sh ip bgp и смотрим получаем ли мы маршруты от соседа:
Код: Выделить всё
AS100# sh ip bgp                                                             
BGP table version is 0, local router ID is 2.2.2.2                     
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, R Removed                               
Origin codes: i - IGP, e - EGP, ? - incomplete                                 
                                                                               
   Network          Next Hop            Metric LocPrf Weight Path             
*> 100.100.100.0/24  0.0.0.0                  0         32768 i                 
                                                                               
Total number of prefixes 1


И че это за фигня? :(

вот конфиги:
Cisco7201:
Код: Выделить всё
interface GigabitEthernet0/0
 ip address 2.2.2.1 255.255.255.252
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface GigabitEthernet0/1
 ip address 200.200.200.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 200.200.200.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 100
 no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 2.2.2.2
ip route 200.200.200.0 255.255.255.0 200.200.200.2
no ip http server
no ip http secure-server

***
далее с freebsd:
zebra.conf
Код: Выделить всё
interface de0
ip address 10.1.1.1/24
!
interface de1
ip address 2.2.2.2/30
!
interface lo0
!
ip route 0.0.0.0 0.0.0.0 2.2.2.1
ip route 100.100.100.0 255.255.255.0 10.1.1.2
!
ip forwarding
!
!
line vty
exec-timeout 0 0

**
Код: Выделить всё
bgpd.conf
router bgp 100
bgp router-id 2.2.2.2
bgp log-neighbor-changes
no synchronization
network 100.100.100.0/24
neighbor 2.2.2.1 remote-as 200
!
line vty

***

de0 в локалку
de1 в циску, тоесть внешка
**
Я бы выложил больше фрагментов сердца, Да не позволяет провайдер...
waxmax
новичок
 
Сообщения: 65
Зарегистрирован: 28 май 2009, 14:55

Re: BGP TEST

Сообщение root » 29 июн 2009, 12:44

1. выполни на циске:
Код: Выделить всё
conf t
ip classless
ip routing
ip subnet-zero
router bgp 200
neighbor 2.2.2.2 version 4
distance bgp 180 200 200
exit
exit
wri


2. а зачем дефолтовый роутинг у них друг на друга смотрит ? зачем тебе вообще дефолт ?

3. в дебаг смотрел ?
положи сессию, затем:
Код: Выделить всё
terminal monitor
debug ip bgp

подними сессию

4.
Код: Выделить всё
ip route 200.200.200.0 255.255.255.0 200.200.200.2

это на циске лишнее, т.к. у тя на ифейсе висит ип 200.200.200.1 и он в из подсети 200.200.200.0/24

5. покажи вывод команды на циске:
Код: Выделить всё
sh ip bgp neighbors
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1887
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: BGP TEST

Сообщение waxmax » 29 июн 2009, 15:15

Код: Выделить всё
c7201#show ip bgp neighbors
BGP neighbor is 2.2.2.2,  remote AS 100, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:05:50
  Last read 00:00:45, last write 00:00:48, hold time is 180, keepalive interval
is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0

                         Sent       Rcvd
    Opens:                  6          6
    Notifications:          0          2
    Updates:                0          6
    Keepalives:           162        160
    Route Refresh:          0          0
    Total:                168        174
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 6, neighbor version 6/0
  Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          1 (Consumes 52 bytes)
    Prefixes Total:                 0          1
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from this peer:              1        n/a
    Total:                                1          0
  Number of NLRIs in the update sent: max 0, min 0

  Address tracking is enabled, the RIB does have a route to 2.2.2.2
  Connections established 6; dropped 5
  Last reset 2d23h, due to Interface flap
  Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 2.2.2.1, Local port: 179
Foreign host: 88.200.156.117, Foreign port: 59235
Connection tableid (VRF): 0

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x7B96CC0C):
Timer          Starts    Wakeups            Next
Retrans             8          0             0x0
TimeWait            0          0             0x0
AckHold             9          7             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0

iss: 3587364770  snduna: 3587364949  sndnxt: 3587364949     sndwnd:  65535
irs:  117862584  rcvnxt:  117862815  rcvwnd:      16154  delrcvwnd:    230

SRTT: 197 ms, RTTO: 984 ms, RTV: 787 ms, KRTT: 0 ms
minRTT: 0 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6

Datagrams (max data segment is 1460 bytes):
Rcvd: 17 (out of order: 0), with data: 9, total data bytes: 230
Sent: 16 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0)
, with data: 8, total data bytes: 178
 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0


*******
а как же мне обьявить свою сетку 200.200.200.0 ?
-
Код: Выделить всё
c7201#terminal monitor
% Console already monitors
c7201#debug ip bgp
BGP debugging is on for address family: IPv4 Unicast

-
если не по дефолтам, то как можно маршруты прописать, если два роутера bgp воткнуты только друг в друга, и больше ни кого нет??
я прост не очень опытный в маршрутизации :) но как могут такие ip route мешать объявлении сетки?

-

Код: Выделить всё
ip classless
ip routing
ip subnet-zero
router bgp 200
neighbor 2.2.2.2 version 4
distance bgp 180 200 200

это все прописал, тоже самое :?
Я бы выложил больше фрагментов сердца, Да не позволяет провайдер...
waxmax
новичок
 
Сообщения: 65
Зарегистрирован: 28 май 2009, 14:55

Re: BGP TEST

Сообщение root » 29 июн 2009, 20:00

1. а теперь покажи show ip bgp neighbors на фре

2.
waxmax писал(а):c7201#debug ip bgp

ну а где сам то дебаг ?
положи линк, подожди пока сессия упадет и поднимай, да и смотри что там происходит по дебагу

3.
waxmax писал(а):если не по дефолтам, то как можно маршруты прописать

иметь дефолт не обязательно, если ты принимаешь full-view от соседа, там будут все маршруты

waxmax писал(а):но как могут такие ip route мешать объявлении сетки?

я не говорил что они мешают, я сказал что это не верно исходя из конфига порта

чудес не бывает, если маршрута нет, а он должен быть, то помочь понять тебе поможет вывод дебага, т.е. в момент установки соединения и передачи маршрутов друг другу

также посмотри вывод команд:
Код: Выделить всё
sh ip bgp neighbors IP-АДРЕС-СОСЕДА advertised-routes

Код: Выделить всё
sh ip bgp neighbors IP-АДРЕС-СОСЕДА received-routes
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1887
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: BGP TEST

Сообщение waxmax » 01 июл 2009, 10:48

Вообщем так!
проблема оказалась до боли проста и банальна. ;)

внутренний ифейс кошки был в дауне!
причем я предварительно воткнул его в пустой свич, что апнуть, но свичь был лампочками не ко мне и оказался не запитанным вообще :D

Зато по ходу даннах тут советов, кое в чем разобрался дополнительно. Спасибо! Только не до конца понял для чего "distance bgp 180 200 200"?

И появился вопрос: на кошках есть такая фигня на ифесах как свой loopback чтоли, который может быть и:
Encapsulation ARPA, loopback set (external)
Keepalive set (10 sec)
а так же и:
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)

как я понял если этот лупбэк в статусе set, то интерфейс всегда в апе независимо от реальных линков, ну и соответственно если нот сет, то автоматом в даун ухоит когда линк падает.
так в чем фишка отдельных loopback0 к примеру и таких лупбеков?
Я бы выложил больше фрагментов сердца, Да не позволяет провайдер...
waxmax
новичок
 
Сообщения: 65
Зарегистрирован: 28 май 2009, 14:55

Re: BGP TEST

Сообщение root » 01 июл 2009, 14:29

waxmax писал(а):внутренний ифейс кошки был в дауне!

тогда все понятно :)
не подумал об этом :)

waxmax писал(а):Только не до конца понял для чего "distance bgp 180 200 200"

прочти доки ;)

waxmax писал(а):так в чем фишка отдельных loopback0 к примеру и таких лупбеков?

сетку можно повесить на лупбэк, тогда не будет таких ситуция как у тя была до этого
лупбэк никогда не падает
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1887
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia


Вернуться в Маршрутизация / Routing

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 3

cron