dynamic routing on p-to-p

Статическая и динамическая, протоколы

dynamic routing on p-to-p

Сообщение buryanov » 30 янв 2013, 15:29

Hi All
есть quagga, cisco, mikrotik в небольшом колличестве стоящее в разных офисах. Стала задача всё это всё это связать vpn.
со стороны cisco:
Код: Выделить всё
interface Tunnel1010
 ip address 172.16.0.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1260
 ip tcp adjust-mss 1400
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 qwerty
 ip ospf cost 10
 load-interval 30
 tunnel source
 tunnel destination
 tunnel mode ipip
!
router ospf 1
 router-id 10.4.250.6
 log-adjacency-changes
 area 0 authentication message-digest
 redistribute connected route-map OSPF_List
 redistribute static route-map OSPF_List
 redistribute rip metric 222222 subnets
 network 172.16.0.0 0.0.0.255 area 0
 network 217.112.209.0 0.0.0.255 area 0
!
ip prefix-list OSPF_List seq 4 permit 192.168.252.0/24
ip prefix-list OSPF_List seq 5 permit 192.168.254.0/24

quagga:
Код: Выделить всё
!
interface gif0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 qwerty
 ip ospf cost 10
!
interface vlan464
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 qwerty
 ip ospf cost 20
!
router ospf
 ospf router-id 10.10.10.249
 redistribute kernel
 redistribute connected route-map OSPF_List
 redistribute static route-map OSPF_List
 network 10.10.10.0/24 area 0.0.0.1
 network 10.10.200.0/24 area 0.0.0.0
 network 10.11.11.0/24 area 0.0.0.0
 network 192.168.224.0/24 area 0.0.0.0
 area 0.0.0.0 authentication message-digest
 area 0.0.0.1 authentication message-digest
 neighbor 10.10.10.253
 neighbor 10.10.200.6
 neighbor 192.168.224.132
!
ip prefix-list OSPF_List seq 5 permit 10.4.0.0/16
!
route-map OSPF_List permit 10
 match ip address prefix-list OSPF_List

gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1280
        tunnel inet -->
        inet6 fe80::21b:21ff:fec8:3489%gif0 prefixlen 64 scopeid 0x13
        inet 10.10.10.254 --> 10.10.10.253 netmask 0xfffffffc
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
        options=1<ACCEPT_REV_ETHIP_VER>
mikrotik
Код: Выделить всё
[dburianov@MikroTik] > /routing ospf export
# jan/30/2013 14:10:09 by RouterOS 6.0rc6
# software id = 0WP7-A39B
#
/routing ospf area
set [ find default=yes ] disabled=yes
/routing ospf instance
set [ find default=yes ] disabled=yes redistribute-connected=as-type-1 redistribute-other-ospf=as-type-1 router-id=172.16.0.1
add name=ospf0 redistribute-bgp=as-type-1 redistribute-connected=as-type-1 redistribute-other-ospf=as-type-1 redistribute-rip=\
    as-type-1 redistribute-static=as-type-1 router-id=172.16.0.1
/routing ospf area
add area-id=0.0.0.1 instance=ospf0 name=area1
add instance=ospf0 name=area0
/routing ospf interface
add authentication=md5 authentication-key=qwerty interface=Tunnel1010 network-type=point-to-point
add authentication=md5 authentication-key=qwerty interface=Tunnel0 network-type=point-to-point
/routing ospf network
add area=area1 network=10.10.10.0/24
add area=area0 network=172.16.0.0/24
если без динамики, то всё работает, на маршрутизаторах есть эзернет линки на другие маршрутизаторы, на которых работает динамика, проблема с тунельными интерфейсами. Как тольно на них поднимается динамика, то сразу вижу:
Код: Выделить всё
gw1 kernel: gif_output: loop detected on gif0
Код: Выделить всё
 %ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of Tunnel1010 67BB7520 - looped chain attempting to stack
 %TUN-5-RECURDOWN: Tunnel1010 temporarily disabled due to recursive routing
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1010, changed state to down
 %OSPF-5-ADJCHG: Process 1, Nbr 172.16.0.1 on Tunnel1010 from FULL to DOWN, Neighbor Down: Interface down or detached
Код: Выделить всё
 route,ospf,info OSPFv2 neighbor 10.4.250.6: state change from Init to Down
 route,ospf,info OSPFv2 neighbor 10.10.10.249: state change from Full to Down
Насколько я понял, читая инет, что это нормально, есть решения этой проблеммы, но толком ничего не нашел. Смена типа маршрутизии (ospf, rip, bgp) не помогает.
Аватара пользователя
buryanov
новичок
 
Сообщения: 25
Зарегистрирован: 29 апр 2009, 18:32

Re: dynamic routing on p-to-p

Сообщение root » 31 янв 2013, 08:13

Скорее всего твоя проблема заключается вот в чем:
При использовании туннелей роутер ессно всегда должен знать маршрут до IP-адреса с которым он строит этот туннель.
Как только ты понимаешь протокол динамической маршрутизации, кто то из твоих роутеров шлет маршрут, который и меняет хождение пакетов до IP-адреса с которым роутер строит туннель и пакеты, которые и образуют туннель, пытаются уйти через этот же туннель что и приводит к падению туннеля.
Соответственно на всех девайсах пропиши статик роуты /32 до адресов с которым этот девайс строит туннели и твоя проблема решится.
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1887
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia


Вернуться в Маршрутизация / Routing

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3