Вопрос по quagga FreeBSD

Статическая и динамическая, протоколы

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 17:15

kudeb писал(а):Спасибо!
Тогда взгляните на bgpd.conf может в нем ошибка...


То, что явно бросается в глаза:
Код: Выделить всё
neighbor 1.1.1.17 route-map TTK-out out

1.1.1.17

Код: Выделить всё
neighbor 3.3.3.3 prefix-list ALL out

Такого префикс-листа не наблюдается в конфигурации

Код: Выделить всё
!route-map TTK-in deny 120
!match ip address prefix-list our-CIDR-blocks

Откуда тут "!" в начале строк?

В остальном - вроде все норм.
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 17:47

Кстати, а покажи ка конфиг zebra
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 18:16

lehisnoe писал(а):Кстати, а покажи ка конфиг zebra

Код: Выделить всё
interface em1
description RTK
ip address 2.2.2.2/30
!
interface em2
description TTK
ip address 1.1.1.1/30
!
interface lo0
!
ip route 0.0.0.0/0 2.2.2.2
ip route 0.0.0.0/0 1.1.1.1
ip route 10.0.0.0/8 Null0 254
ip route 172.16.0.0/12 Null0 254
ip route 192.168.0.0/16 Null0 254
ip route x.x.212.0/22 Null0 254
ip route x.x.212.0/24 172.20.100.2
ip route x.x.213.0/24 172.20.100.2
ip route x.x.214.0/24 172.20.100.2
ip route x.x.215.0/24 172.20.100.2
!
ip forwarding
!
!
line vty
exec-timeout 0 0
!
log file /usr/local/etc/quagga/zebra.log
!
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 18:19

lehisnoe писал(а):То, что явно бросается в глаза:
Код: Выделить всё
neighbor 1.1.1.17 route-map TTK-out out

1.1.1.17

Опечатка. 1.1.1.1

lehisnoe писал(а):
Код: Выделить всё
neighbor 3.3.3.3 prefix-list ALL out

Такого префикс-листа не наблюдается в конфигурации

раньше был, потом убрал

lehisnoe писал(а):
Код: Выделить всё
!route-map TTK-in deny 120
!match ip address prefix-list our-CIDR-blocks

Откуда тут "!" в начале строк?

закомментировано, тоже в процессе опытов, пробовал...
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 18:23

lehisnoe писал(а):Сессии установлены, маршруты "приезжают" - уже хорошо.
А маршрутные карты пробовал убирать? Просто у нас нету еще ни одной квагги на 8.1...


Сначала стояла FreeBSD 8.0, пробовал убирать роут-мапы, сначала загрузилась таблица маршрутов... но машина тупила, и зависала наглухо.
Было решено обновиться до 8.1 после этого, маршруты ни как не хотят грузиться(
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение lehisnoe » 14 сен 2010, 19:47

А дай вывод
Код: Выделить всё
zebra# sh ip route summary


Было решено обновиться до 8.1 после этого, маршруты ни как не хотят грузиться(

На 8.1 маршруты не помещаются в кернел-таблу роутинга даже без роут-мап?

Если да - то дебажь зебру:
Код: Выделить всё
zebra# debug zebra kernel
zebra# debug zebra rib
zebra# term mon


И дебаг, ессесно, сюда :)
No users
No troubles
No money
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
lehisnoe
Site Admin
 
Сообщения: 539
Зарегистрирован: 11 июн 2008, 14:09
Откуда: Moscow

Re: Вопрос по quagga FreeBSD

Сообщение root » 14 сен 2010, 20:20

версия quagga какая ?
покажи вывод:
Код: Выделить всё
pkg_info | grep quagga
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1882
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 20:57

root писал(а):версия quagga какая ?
покажи вывод:
Код: Выделить всё
pkg_info | grep quagga


quagga-0.99.16
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение kudeb » 14 сен 2010, 21:02

Разобрался, почему у меня машина вешалась. Был включен роутинг (/sbin/routed).
Убрал prefix-list ALL перезапустил quagga и маршруты загрузились.
Теперь выплыла такая проблема:
Трафик через РТК идет нормально, а вот через ТТК не идет, хотя в kernel route
Код: Выделить всё
...
222.96.9.0/24      1.1.1.1     UG1         0        0    em1
222.96.10.0/24     1.1.1.1     UG1         0        0    em1
222.124.40.0/22    2.2.2.2        UG1         0        0    em2
222.124.76.0/23    2.2.2.2       UG1         0        0    em2
222.124.94.0/23    2.2.2.2        UG1         0        0    em2
222.124.108.0/23   2.2.2.2        UG1         0        0    em2
222.124.116.0/23   2.2.2.2        UG1         0        0    em2
222.124.240.0/23   2.2.2.2        UG1         0        0    em2
222.154.0.0/19     1.1.1.1     UG1         0        0    em1
222.154.32.0/19    1.1.1.1     UG1         0        0    em1
222.154.64.0/19    1.1.1.1     UG1         0        0    em1
222.154.96.0/19    1.1.1.1     UG1         0        0    em1
222.154.160.0/19   1.1.1.1     UG1         0        0    em1
222.154.192.0/19   1.1.1.1     UG1         0        0    em1
222.154.224.0/19   1.1.1.1     UG1         0        0    em1
...
kudeb
новичок
 
Сообщения: 24
Зарегистрирован: 14 сен 2010, 15:54

Re: Вопрос по quagga FreeBSD

Сообщение root » 14 сен 2010, 21:55

kudeb писал(а):Разобрался

гуд

kudeb писал(а):Трафик через РТК идет нормально, а вот через ТТК не идет, хотя в kernel route

а с чего ты решил что он должен туда идти ?
ты обращаешся к какой подсети где quagga показывает что маршрут к ней best через ТТК, а трафик идет в РТК ? так что ли ?
что то сильно сомневаюсь что так

так ты уверен что путь до src-адреса лучше через ТТК ?

да и вообще, ты о входящем к тебе трафике или исходящем ?

судя по приведенному тобой bgpd.conf "дефолтовые" локал-префы у тя по обоим каналам равны, а значит, при прочих равных, best маршрут выбирается обычным для BGP способом
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1882
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Пред.След.

Вернуться в Маршрутизация / Routing

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron