Помогите с кваггой

Статическая и динамическая, протоколы

Помогите с кваггой

Сообщение jooe008 » 25 мар 2018, 22:51

Всем добрый день!
Являемся небольшим провайдером интернета. RIPE выделил AS и блок адресов /22 , к тому же пров у которого покупаем инет сдает в аренду сеть /24.
Всем этим рулит микротик на базе dell-R610. На данный момент все работает хорошо. Договорились с еще одним провом, взять 1G и у него для резерва и так как у него есть выход на местную локальную сеть. Подключили второго прова к микротику, и тут я заметил что у микротика несколько ограниченные возможности в плане bgp. Решили перейти на кваггу, и дабы не ронять всю сеть сразу, решили поставить кваггу между провом и микротиком и постепенно перенести все на кваггу. И тут начались проблемы, маршруты анонсятся full view принимаю на квагге, тоже и на микротике.
Трассировка маршрутов работает нормально, все пингуется но 90% страниц в инете не открывается, какие то хосты доступны какие то нет. При попытке подключится к какому нибудь проблемному хосту по wget с самой квагги, пишет connected и все там зависает. Вобщем голову ломаю уже третий день,
эксперименты с 3 до 6 ночи , настроение сами понимает какое. Что самое интересное, подключался кваггой к микротику и анонсировал одну /24 подсеть с квагги, все работало как часы. Прошу помочь разобратся с этой проблемой. Прилагаю текущие конфиги.
Код: Выделить всё
-----------------------bgpd.conf
!
! Zebra configuration saved from vty
!   2018/03/25 04:47:39
!
hostname AS11111
password ******
enable password ******
log file /var/log/quagga/bgpd.log
!
router bgp 11111
 bgp router-id 1.1.3.253
 neighbor 1.1.2.9 remote-as 22222
 neighbor 1.1.2.9 description ISP1
 neighbor 1.1.2.9 password ******
 neighbor 1.1.2.9 soft-reconfiguration inbound
 neighbor 1.1.2.9 route-map ISP1-in in
 neighbor 1.1.2.9 route-map ISP1-out out
 neighbor 1.1.3.9 remote-as 11111
 neighbor 1.1.3.9 description MKT
 neighbor 1.1.3.9 password ******
 neighbor 1.1.3.9 next-hop-self
 neighbor 1.1.3.9 soft-reconfiguration inbound
 neighbor 1.1.3.9 route-map MKT-in in
 neighbor 1.1.3.9 route-map MKT-out out
!
ip prefix-list bogons description bogus nets
ip prefix-list bogons seq 20 permit 127.0.0.0/8 le 32
ip prefix-list bogons seq 30 permit 10.0.0.0/8 le 32
ip prefix-list bogons seq 35 permit 172.16.0.0/12 le 32
ip prefix-list bogons seq 40 permit 192.168.0.0/16 le 32
ip prefix-list bogons seq 45 permit 169.254.0.0/16 le 32
ip prefix-list bogons seq 50 permit 224.0.0.0/4 le 32
ip prefix-list bogons seq 55 permit 240.0.0.0/4 le 32
ip prefix-list upstream-out description My upstream networks
ip prefix-list upstream-out seq 15 permit 2.2.6.0/22
ip prefix-list upstream-out seq 16 permit 2.2.6.0/24
ip prefix-list upstream-out seq 17 permit 2.2.7.0/24
ip prefix-list upstream-out seq 18 permit 2.2.8.0/24
ip prefix-list upstream-out seq 19 permit 2.2.9.0/24
ip prefix-list upstream-out seq 20 permit 1.1.3.0/24
!
ip as-path access-list 1 permit _6451[2-9]_
ip as-path access-list 1 permit _645[2-9][0-9]_
ip as-path access-list 1 permit _64[6-9][0-9][0-9]_
ip as-path access-list 1 permit _65[0-9][0-9][0-9]_
!
route-map ISP1-in deny 100
 match as-path 1
!
route-map ISP1-in deny 110
 match ip address prefix-list bogons
!
route-map ISP1-in permit 200
 set local-preference 200
!
route-map ISP1-out deny 100
 match ip address prefix-list upstream-out
!
route-map ISP1-out permit 200
 set local-preference 200
!
route-map MKT-in deny 100
 match as-path 1
!
route-map MKT-in deny 110
 match ip address prefix-list bogons
!
route-map MKT-in permit 200
 set local-preference 200
!
route-map MKT-out permit 100
 match ip address prefix-list upstream-out
!
route-map MKT-out deny 200
!
line vty
!

Код: Выделить всё
----------------------zebra.conf
!
! Zebra configuration saved from vty
!   2018/03/24 00:17:46
!
hostname AS11111
password ******
enable password ******
log file /var/log/quagga/zebra.log
!
interface eth0
 ip address 1.1.3.50/30
 ipv6 nd suppress-ra
!
interface eth1
 ipv6 nd suppress-ra
!
interface eth2
 ipv6 nd suppress-ra
!
interface eth2.205
 ipv6 nd suppress-ra
!
interface eth3
 ipv6 nd suppress-ra
!
interface eth3.101
 ip address 1.1.2.10/29
 ipv6 nd suppress-ra
!
interface lo
!
interface lo0
 ip address 1.1.3.253/32
 ipv6 nd suppress-ra
!
ip forwarding
!
!
line vty
!

Код: Выделить всё
--------------mikrotik-routing-bgp-export
# mar/25/2018 16:15:55 by RouterOS 6.34.2
#
/routing bgp instance
set default as=11111 router-id=1.1.2.253
add as=11111 name="bgp-to-quagga" redistribute-other-bgp=yes
/routing bgp network
add network=1.1.3.0/24 synchronize=no
add network=2.2.6.0/22 synchronize=no
add network=2.2.6.0/24 synchronize=no
add network=2.2.7.0/24 synchronize=no
add network=2.2.8.0/24 synchronize=no
add network=2.2.9.0/24 synchronize=no
/routing bgp peer
add in-filter=AS11111-bgp-in instance="bgp-to-quagga" name=peer-to-quagga \
    out-filter=AS11111-bgp-out remote-address=1.1.3.50 remote-as=11111 \
    tcp-md5-key=****** ttl=default
-------------mikrotik-routing-filter-export
add action=discard chain=AS11111-bgp-in prefix=10.0.0.0/8
add action=discard chain=AS11111-bgp-in prefix=192.168.0.0/16
add action=discard chain=AS11111-bgp-in prefix=172.16.0.0/12
add action=discard chain=AS11111-bgp-in prefix=169.254.0.0/16
add action=discard chain=AS11111-bgp-in prefix=224.0.0.0/4
add action=discard chain=AS11111-bgp-in prefix=240.0.0.0/4
add action=discard chain=AS11111-bgp-in prefix=127.0.0.0/8
add action=discard chain=AS11111-bgp-in prefix=2.2.6.0/22
add action=discard chain=AS11111-bgp-in prefix=2.2.6.0/24
add action=discard chain=AS11111-bgp-in prefix=2.2.7.0/24
add action=discard chain=AS11111-bgp-in prefix=2.2.8.0/24
add action=discard chain=AS11111-bgp-in prefix=2.2.9.0/24
add action=discard chain=AS11111-bgp-in prefix=1.1.3.0/24
add action=accept chain=AS11111-bgp-in set-bgp-local-pref=200
add action=accept chain=AS11111-bgp-out prefix=2.2.6.0/22
add action=accept chain=AS11111-bgp-out prefix=2.2.6.0/24
add action=accept chain=AS11111-bgp-out prefix=2.2.7.0/24
add action=accept chain=AS11111-bgp-out prefix=2.2.8.0/24
add action=accept chain=AS11111-bgp-out prefix=2.2.9.0/24
add action=accept chain=AS11111-bgp-out prefix=1.1.3.0/24
add action=discard chain=AS11111-bgp-out


Прошу сильно не пинать, больших знаний в этой сфере у меня нет, но я стараюсь.
jooe008
проходил мимо
 
Сообщения: 4
Зарегистрирован: 23 мар 2018, 14:52

Re: Помогите с кваггой

Сообщение root » 26 мар 2018, 09:54

jooe008 писал(а):Трассировка маршрутов работает нормально, все пингуется

Тогда причем тут quagga (роутинг) ?
jooe008 писал(а):90% страниц в инете не открывается

Смотреть в сторону MTU и MSS.

P.S.
jooe008 писал(а):Прошу сильно не пинать, больших знаний в этой сфере у меня нет

Это не является оправданием.
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1872
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: Помогите с кваггой

Сообщение jooe008 » 27 мар 2018, 00:08

root писал(а):Тогда причем тут quagga (роутинг) ?

При добавлении в разрыв между микротиком и провом машины с кваггой и начались проблемы.
Конфиги проверял, ничего подозрительного вроде не нашел, поэтому и обратился за помощью.

root писал(а):Смотреть в сторону MTU и MSS.

Большое спасибо за наводку, скорее всего так и есть по умолчанию 1500, а в микротике было выставлено 9000.
Не знал что если выставлен неправильный MTU, то симптомы именно такие.
Сегодня ночью проверю и отпишусь.

root писал(а):Это не является оправданием.

Я и не оправдываюсь. Думаю что не грех спросить то чего не знаешь
jooe008
проходил мимо
 
Сообщения: 4
Зарегистрирован: 23 мар 2018, 14:52

Re: Помогите с кваггой

Сообщение jooe008 » 27 мар 2018, 03:22

Вобщем все получилось! Огромное спасибо! С конфигами которые приготовил заранее все завелось с полпинка.
На пиво к сожалению могу поставить только с пейпала, если есть акк добавьте, буду рад помочь вашему ресурсу.
jooe008
проходил мимо
 
Сообщения: 4
Зарегистрирован: 23 мар 2018, 14:52

Re: Помогите с кваггой

Сообщение root » 27 мар 2018, 08:34

Симптом всегда один - тяжелый трафик (тяжелая web страница) не пролазит, мелкий трафик (ping, traceroute, web страница с "hellow world") пролазят без проблем.
jooe008 писал(а):При добавлении в разрыв между микротиком и провом машины с кваггой и начались проблемы.

Это не говорит о том, что виновата quagga. quagga это набор демонов роутинга, а раз роуты уходят и приходят, то причем тут Курпатов ?
jooe008 писал(а):все получилось

А ларчик, как обычно, просто открывался.
jooe008 писал(а):с пейпала, если есть акк добавьте

Нету.
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1872
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia


Вернуться в Маршрутизация / Routing

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 9