не вставляется opt 82

Все остальное

не вставляется opt 82

Сообщение kid79 » 07 сен 2020, 16:07

Добрый день. возникла небольшая проблема с подстановкой opt 82 в dhcp сервер.
есть циска с настроенный ip unnabmered влан на абонента. захотелось расширить функционал влан на свич. настроил дополнительный лупбэк интерфейс , повесил на него ip , но в логах дхцп сервера вижу что тестовый роутер не может получить ип.

конфиг дхцп следующий.\
Код: Выделить всё
authoritative;
ddns-update-style none;
log-facility local7;
always-broadcast on;
shared-network ISP {
  subnet 172.10.0.0 netmask 255.255.255.240 {
  }
subnet 192.168.27.0 netmask 255.255.255.0 {
            option domain-name-servers 176.111.248.126, 8.8.8.8;
            option subnet-mask 255.255.255.0;
            option routers 192.168.27.1;
            max-lease-time 1296000;
            default-lease-time 604800;
            include "/etc/dhcp/192.168.27.0.conf";
        }

}
192.168.27.0.conf
class "inv_sw_192.168.27.2" {
match if (
    binary-to-ascii(16, 8, ":", suffix(option agent.remote-id, 6)) = "e8:cc:18:ce:dc:0"
    and
    binary-to-ascii(10, 8, "", suffix(option agent.circuit-id, 1)) = "2"
);
    }
    pool {
range 192.168.27.2;
allow members of "inv_sw_192.168.27.2";
    }

на циске произвел настройки
Код: Выделить всё
ip dhcp relay information policy keep
ip dhcp relay information trust-all
ip dhcp snooping vlan 1-99,101-701,703-904,906-907,909-1000,1006-2000,2002-3000
ip dhcp snooping information option format remote-id hostname
no ip dhcp snooping verify mac-address
no ip dhcp snooping verify no-relay-agent-address
ip dhcp snooping
vtp mode transparent
interface Loopback5
 ip address 192.168.27.1 255.255.255.0
 no ip redirects
 no ip unreachables
interface Loopback10
 description users gateway
ip address 192.168.7.1 255.255.255.0
 ip address 192.168.6.1 255.255.255.0 secondary
 ip address 192.168.5.1 255.255.255.0 secondary
no ip redirects
 no ip unreachables
interface GigabitEthernet1/27
 description TEST
 switchport trunk allowed vlan 100,4001
 switchport mode trunk


interface Vlan4001
 ip unnumbered Loopback5
 ip helper-address 172.10.0.2
ip route 0.0.0.0 0.0.0.0 10.255.255.5



подключаю в 27 порт циски длинк 3200 и во второй порт роутер.
на аплинке настраиваю транк влан управления и 4001.
абоненту делаю антаг 4001.
если я правильно понимаю то на свиче настраивать релей нет необходимости т.к релит циска. в логах дхсп сервера вижу дисковеры без ответа
Код: Выделить всё
DHCPDISCOVER from 64:ee:b7:14:0a:1e via 192.168.27.1: network ISP: no free leases

что я делаю не так и куда еще посмотреть?
kid79
новичок
 
Сообщения: 8
Зарегистрирован: 15 ноя 2010, 08:12

Re: не вставляется opt 82

Сообщение root » 08 сен 2020, 15:12

топик dhcp option82 смотрели ?
добавьте логирование в конфиге
так же обратите внимание, что мак у вас в конфиге и в логе отличается.
так же смотреть что показывает tcpdump.
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1887
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: не вставляется opt 82

Сообщение kid79 » 09 сен 2020, 10:44

да указанный топик я прочитал. схему включения абонента прилагаю ниже.
Изображение
в конфиг дхцп сервера добавил логирование.
authoritative;
ddns-update-style none;
log-facility local7;
always-broadcast on;

if exists agent.circuit-id {
log(info, concat("Lease"," IP ",binary-to-ascii(10, 8,".",leased-address),
" MAC ",binary-to-ascii(16,8,":",substring(hardware,1, 6)),
" port ",binary-to-ascii(10,16, "",substring(option agent.circuit-id, 4,
2)),
" VLAN ",binary-to-ascii(10, 16,"",substring(option agent.circuit-id, 2, 2))
));
}
shared-network isp{
subnet 172.10.0.0 netmask 255.255.255.240 {
}
subnet 192.168.27.0 netmask 255.255.255.0 {
option domain-name-servers 176.111.248.126, 8.8.8.8;
option subnet-mask 255.255.255.0;
option routers 192.168.27.1;
max-lease-time 1296000;
default-lease-time 604800;
include "/etc/dhcp/192.168.27.0.conf";
}

}

конфиг зоны
class "inv_sw_192.168.27.2" {
match if (
binary-to-ascii(16, 8, ":", suffix(option agent.remote-id, 6)) = "e8:cc:18:ce:dc:0"
and
binary-to-ascii(10, 8, "", suffix(option agent.circuit-id, 1)) = "2"
);
}
pool {
range 192.168.27.2;
allow members of "inv_sw_192.168.27.2";
}

в циске где агрегация вланов тоже сделал небольшие изменения настроек.
ip dhcp relay information policy keep
ip dhcp relay information trust-all
ip dhcp snooping vlan 1-99,101-701,703-904,906-907,909-1000,1006-2000,2002-3000
ip dhcp snooping information option format remote-id hostname
ip dhcp snooping
interface Loopback10
description users gateway
ip address 192.168.27.1 255.255.255.0 secondary
ip address 176.111.xxx.1 255.255.255.0
no ip redirects
no ip unreachables
interface Vlan4001
ip unnumbered Loopback10
ip helper-address 172.10.0.2
ip route 0.0.0.0 0.0.0.0 10.255.255.5

абон свич
vlan MNG управления
vlan 4001 абон
Command: show dhcp_local_relay

DHCP/BOOTP Local Relay Status : Enabled
DHCP/BOOTP Local Relay VID List : 4001

DHCP Relay Agent Information Option 82 Circuit ID : Default
DHCP Relay Agent Information Option 82 Remote ID : E8-CC-18-CE-DC-00
show dhcp_local_relay option_82 ports 1-26

Port Option 82
Policy
---- ---------
1 keep
2 keep
на всех портах Policy keep

делаю дамп на дхцп сервере
176.111.xxx.1.67 > 172.10.0.2.67: BOOTP/DHCP, Request from 64:ee:b7:14:0a:1e, length 552, hops 1, xid 0x1e4a6015, Flags [none]
Gateway-IP 176.111.xxx.1
Client-Ethernet-Address 64:ee:b7:14:0a:1e
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Discover
Client-ID Option 61, length 7: ether 64:ee:b7:14:0a:1e
Vendor-Class Option 60, length 8: "MSFT 5.0"
Requested-IP Option 50, length 4: 192.168.27.2
Parameter-Request Option 55, length 12:
Subnet-Mask, Default-Gateway, Domain-Name-Server, Domain-Name
BR, Static-Route, YD, YS
NTP, Netbios-Name-Server, Classless-Static-Route-Microsoft, Classless-Static-Route
Agent-Information Option 82, length 29:
Circuit-ID SubOption 1, length 6: ^@^D^OM-!^@^B
Remote-ID SubOption 2, length 19: ^A^QE8-CC-18-CE-DC-00
10:36:41.370527 IP (tos 0x0, ttl 254, id 55673, offset 0, flags [none], proto UDP (17), length 580)
176.111.xxx.1.67 > 172.10.0.2.67: BOOTP/DHCP, Request from 64:ee:b7:14:0a:1e, length 552, hops 1, xid 0x1e4a6015, Flags [none]
Gateway-IP 176.111.xxx.1
Client-Ethernet-Address 64:ee:b7:14:0a:1e
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Discover
Client-ID Option 61, length 7: ether 64:ee:b7:14:0a:1e
Vendor-Class Option 60, length 8: "MSFT 5.0"
Requested-IP Option 50, length 4: 192.168.27.2
Parameter-Request Option 55, length 12:
Subnet-Mask, Default-Gateway, Domain-Name-Server, Domain-Name
BR, Static-Route, YD, YS
NTP, Netbios-Name-Server, Classless-Static-Route-Microsoft, Classless-Static-Route
Agent-Information Option 82, length 29:
Circuit-ID SubOption 1, length 6: ^@^D^OM-!^@^B
Remote-ID SubOption 2, length 19: ^A^QE8-CC-18-CE-DC-00


а в лог сервера сыпется сообщение discover no free leases
вот еще. на циске смотрю статистику dhcp snooping
show ip dhcp snooping statistics detail
Packets Processed by DHCP Snooping = 570
Packets Dropped Because
IDB not known = 0
Queue full = 0
Interface is in errdisabled = 0
Rate limit exceeded = 0
Received on untrusted ports = 0
Nonzero giaddr = 0
Source mac not equal to chaddr = 0
No binding entry = 0
Insertion of opt82 fail = 0
Unknown packet = 0
Interface Down = 0
Unknown output interface = 0
Misdirected Packets = 0
Packets with Invalid Size = 0
Packets with Invalid Option = 0
kid79
новичок
 
Сообщения: 8
Зарегистрирован: 15 ноя 2010, 08:12

Re: не вставляется opt 82

Сообщение kid79 » 09 сен 2020, 16:20

почему запросы приходят из shared-network ?
DHCPDISCOVER from 64:ee:b7:14:0a:1e via 176.111.xxx.1: network isp: no free leases
kid79
новичок
 
Сообщения: 8
Зарегистрирован: 15 ноя 2010, 08:12

Re: не вставляется opt 82

Сообщение root » 11 сен 2020, 10:17

kid79 писал(а):добавил логирование

только не понятно почему вы логируете одно, а в классе матчите абсолютно другое.
логирование, что логично, нужно для условий, которые вы используете в классе и оно должно показать, что под class "inv_sw_192.168.27.2" запрос не попадает, раз ответ no free leases
логирование и должно ответить на вопрос - почему не попадает.
kid79 писал(а):почему запросы приходят из shared-network ?

потому что так составлен ваш конфиг dhcp и потому что так и должно быть в вашем случае.
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1887
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia


Вернуться в Разное (networks)

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron