Q-in-Q + Ubuntu

Все остальное

Q-in-Q + Ubuntu

Сообщение Андрей » 30 авг 2017, 13:02

Привет всем.
Есть ubuntu сервер с установленным и настроенным интерфейсом.
Конфиг:
Код: Выделить всё
# The loopback network interface
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual
post-up ip link add link eno1 eno1.440 type vlan proto 802.1ad id 440
post-up ip link set eno1.440 up

auto eno1.440
iface eno1.440 inet manual
post-up ip link add link eno1.440 eno1.440.1 type vlan proto 802.1Q id 1
post-up ip link set eno1.440.1 up
post-up ip link add link eno1.440 eno1.440.770 type vlan proto 802.1Q id 770
post-up ip link set eno1.440.770 up
post-up ip link add link eno1.440 eno1.440.771 type vlan proto 802.1Q id 771
post-up ip link set eno1.440.771 up

auto eno1.440.1
iface eno1.440.1 inet static
   address 10.10.254.253
   netmask 255.255.0.0
   dns-nameservers 8.8.8.8
   up route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.10.0.1

auto eno1.440.770
iface eno1.440.770 inet static
        address 10.140.1.253
        netmask 255.255.255.0
      network 10.140.1.0
        broadcast 10.140.1.255
        vlan_raw_device eno1

auto eno1.440.771
iface eno1.440.771 inet static
        address 10.140.2.253
        netmask 255.255.255.0
      network 10.140.2.0
        broadcast 10.140.2.255
        vlan_raw_device eno1


Есть cisco 3550, которая умеет QinQ (согласно меню):
Код: Выделить всё
Building configuration...

Current configuration : 2886 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TEST_3550_24
!
enable secret 5 $1$S8x8$zsHUcwS0PvQm8OHs65bOE0
enable password ena1
!
no aaa new-model
ip subnet-zero
ip routing
!
vtp domain CISCO
vtp mode transparent
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 1
 tb-vlan1 1002
 tb-vlan2 1003
!
vlan 440,770-771,1000
!
vlan 1002
 tb-vlan1 1
 tb-vlan2 1003
!
vlan 1003
 tb-vlan1 1
 tb-vlan2 1002
 parent 1005
!
vlan 1004
 bridge 1
 stp type ibm
!
vlan 1005
 bridge 1
!
!
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 440
 switchport mode dot1q-tunnel
 switchport nonegotiate
 no cdp enable
!
interface FastEthernet0/2
 switchport mode dynamic desirable
!
...
!interface FastEthernet0/24
 switchport mode dynamic desirable
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1000
 switchport trunk allowed vlan 1,770
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 440
 switchport mode dot1q-tunnel
 no cdp enable
!
interface Vlan1
 ip address 10.10.13.75 255.255.0.0
!
interface Vlan770
 ip dhcp relay information trusted
 ip address 10.140.1.1 255.255.255.0
 ip helper-address 10.10.254.127
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.254.253
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
 password nag
 login
line vty 5 15
 password nag
 login
!
end


Пингую с ubuntu 10.140.1.1 - не видит, vlan 1 тоже не видит. Что я делаю не так?
Спасбо.
.ı|ı..ı|ı.
Андрей
местный житель
 
Сообщения: 1028
Зарегистрирован: 14 янв 2009, 13:37
Откуда: Оренбургская область

Re: Q-in-Q + Ubuntu

Сообщение dimondack » 31 авг 2017, 15:49

!
interface Vlan770
ip dhcp relay information trusted
ip address 10.140.1.1 255.255.255.0
ip helper-address 10.10.254.127
!

!
interface Vlan1
no ip address
!
Нас определяет то, что мы делаем.
Аватара пользователя
dimondack
новичок
 
Сообщения: 71
Зарегистрирован: 21 янв 2015, 13:00

Re: Q-in-Q + Ubuntu

Сообщение Андрей » 01 сен 2017, 12:08

В конфиге так:
Код: Выделить всё
!
interface Vlan1
 ip address 10.10.13.75 255.255.0.0
!
interface Vlan770
 ip dhcp relay information trusted
 ip address 10.140.1.1 255.255.255.0
 ip helper-address 10.10.254.127
!
.ı|ı..ı|ı.
Андрей
местный житель
 
Сообщения: 1028
Зарегистрирован: 14 янв 2009, 13:37
Откуда: Оренбургская область

Re: Q-in-Q + Ubuntu

Сообщение dimondack » 01 сен 2017, 12:50

Да, вот и предлагается убрать ip c Vlan1
может это поможет

У нас есть коммутатор Quidway s3026 , который не разрешает прикручивать
одновременно на двух и более разных interface vlan ip адреса.


По крайней мере у меня не получилось ))
Нас определяет то, что мы делаем.
Аватара пользователя
dimondack
новичок
 
Сообщения: 71
Зарегистрирован: 21 янв 2015, 13:00

Re: Q-in-Q + Ubuntu

Сообщение root » 01 сен 2017, 14:54

dimondack писал(а):который не разрешает прикручивать одновременно на двух и более разных interface vlan ip адреса.

Ты написал ключевое - "Quidway s3026 коммутатор", потому и не разрешает.
А 3550 это конечно тоже коммутатор, но с оговоркой - в нем присутствует поддержка L3, т.е. может выступать в роли маршрутизатора, но с ограниченными ресурсами (памятью) под маршрутную инфу.

По Ubuntu я точно не помогу, тут должен быть рвотный смайл, но могу сказать что "пингую - не видит" это слова для блондинки секретаря, а не для технаря. Для технаря это траблшут - начиная от L2 уровня и заканчивая L3 уровнем, который включает в себя маки, ARP, dump и пр.
Соответственно возникает вопрос: А траблшут где ?
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1847
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: Q-in-Q + Ubuntu

Сообщение Андрей » 04 сен 2017, 08:07

Код: Выделить всё
# tcpdump -e -i eno1 host 10.10.254.253
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eno1, link-type EN10MB (Ethernet), capture size 262144 bytes
09:45:20.780265 00:11:92:15:45:80 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 80: 10.114.16.4.50131 > 10.10.254.253.domain: 30835+ A? ping3.teamviewer.com. (38)
09:45:20.783388 00:16:47:01:9d:80 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 76: 10.115.9.57.49180 > 10.10.254.253.domain: 2+ A? dns.msftncsi.com. (34)
09:45:20.793782 00:14:f2:25:70:80 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 78: 10.2.91.245.45745 > 10.10.254.253.domain: 1234+ A? a.root-servers.net. (36)
09:45:20.801661 00:0d:28:ea:88:00 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 85: 10.103.9.121.64539 > 10.10.254.253.domain: 45150+ A? tpc.googlesyndication.com. (43)
09:45:20.811932 00:11:21:a2:2e:00 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 84: 10.160.8.14.49970 > 10.10.254.253.domain: 58999+ A? ssl.google-analytics.com. (42)
09:45:20.836550 00:0d:28:ea:88:00 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 74: 10.103.9.121.60247 > 10.10.254.253.domain: 42256+ A? www.google.com. (32)
09:45:20.837098 00:0d:28:ea:88:00 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 87: 10.103.9.121.58945 > 10.10.254.253.domain: 4630+ A? googleads.g.doubleclick.net. (45)
09:45:20.837114 00:0d:28:ea:88:00 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 75: 10.103.9.121.50811 > 10.10.254.253.domain: 17599+ A? www.gstatic.com. (33)
09:45:20.864508 00:11:5c:ff:02:80 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 73: 10.3.9.134.63451 > 10.10.254.253.domain: 45352+ A? go.trouter.io. (31)
09:45:20.911001 00:04:80:74:6f:00 (oui Unknown) > Broadcast, ethertype ARP (0x0806), length 60: Request who-has 10.10.254.253 tell 10.10.0.1, length 46
09:45:20.936944 00:0d:65:39:e0:80 (oui Unknown) > 0c:c4:7a:86:a3:b2 (oui Unknown), ethertype IPv4 (0x0800), length 76: 10.119.5.20.51939 > 10.10.254.253.domain: 33540+ A? go.microsoft.com. (34)

Вот такое в dump'е.

На самом коммутаторе не могу задать ethertype, т.к. нет такой команды вовсе.
https://www.atraining.ru/vlan-tag-switching-in-detail/ - руководствовался этой статьей.
.ı|ı..ı|ı.
Андрей
местный житель
 
Сообщения: 1028
Зарегистрирован: 14 янв 2009, 13:37
Откуда: Оренбургская область

Re: Q-in-Q + Ubuntu

Сообщение root » 08 сен 2017, 12:21

И ? что это за маки ? Какой из них "пингую" ?
Зачем слушать себя же ? 10.10.254.253 это же сама это система. Дампать надо по маку отправителя и слушать, в первую очередь, на саб-интерфесе, а уж тока потом на основном.
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1847
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia


Вернуться в Разное (networks)

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 6

cron