cisco as5350 - dial-up и VoIP

Обсуждаем, спрашиваем, помогаем в настройке VoIP

Re: cisco as5350 - dial-up и VoIP

Сообщение zaikini » 12 фев 2010, 23:58

waxmax писал(а):мне прост надо хоть чтото заработало из того что я имею, и отталкиваца от этого

тогда для начала рекомендую ознакомиться с этой статьей
http://www.cisco.com/en/US/docs/routers ... voice.html,
это первое
второе нарисовать схему, аналогичную той которая приводится в статье, с указанием ip адресов и номеров телефонов на каждой стороне
третье, поставить какой-то простенький сип сервер типа teksip для windows чтобы не лезть в дебри, можно регистрировать и на роутере, но для этого должен быть специальный софт
четвертое регистриуем dlink на установленном сервере и пытаемся звонить (можно наверно и не регистрировать длинк, но ни разу этого делать не пытался)
результаты со схемой и собственными наблюдениями отписываем в форум.
Дело в том что готовый рецепт не даст понимания, напишите что уже сделали, что попробывали позвонить но не выходит, прочли вот здесь и здесь, и настроили роутер вот по такой схеме, тогда будет понятно на каком этапе вам помочь, а просто рисовать рабочий конфиг на мой взгляд не комильфо..
Аватара пользователя
zaikini
новичок
 
Сообщения: 50
Зарегистрирован: 15 май 2009, 11:32

Re: cisco as5350 - dial-up и VoIP

Сообщение root » 13 фев 2010, 13:29

+1 к zaikini
в некоторых вещах нужно самому пройти весь "путь"
иначе потом будут сложности в понимании
а схема действительно нужна, для полного понимания что должно получиться, так легче осозновать что нуна делать

например настроить "коленочный" вариант (чтобы хоть как то работало) Asterisk`a не сложно
поправить нуна всего несколько конфиг файлов:
    sip.conf
    users.conf
    extensions.conf
просто нуна почитать мальца
когда я начал разбираться в нем, то мне очень помогли:
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1882
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: cisco as5350 - dial-up и VoIP

Сообщение waxmax » 15 фев 2010, 15:11

второе нарисовать схему, аналогичную той которая приводится в статье, с указанием ip адресов и номеров телефонов на каждой стороне


это о табличке Dial-Peer Configuration Table ?

не понял вней только одно:
это для двух отдельных шлюзов? удаленных друг от друга?
а какой это имеет отношение к as5350
или
надо это на ней прописать на одной?
Я бы выложил больше фрагментов сердца, Да не позволяет провайдер...
waxmax
новичок
 
Сообщения: 65
Зарегистрирован: 28 май 2009, 14:55

Re: cisco as5350 - dial-up и VoIP

Сообщение zaikini » 15 фев 2010, 16:54

ты нарисуй а мы поправим
Аватара пользователя
zaikini
новичок
 
Сообщения: 50
Зарегистрирован: 15 май 2009, 11:32

Re: cisco as5350 - dial-up и VoIP

Сообщение waxmax » 17 фев 2010, 14:58

Вообщем Циска отвечает на сип телефон(zyxel p-2602h ee).
зухель пишет, что не регестритует.
по http://www.cisco.com/en/US/docs/ios/12_ ... sip72.html
вроди как циска должна все делать, тоест быть сип сервером. так и прописал, но чтото тут не то.
может както дебаг поможет???

в FastEthernet0/0 воткнут телевон через zyxel p-2602h ee,
FastEthernet0/1 в локалку 172.16.2.0

на zyxel p-2602h прописан номер 2222222@172.16.22.6
и аутентификационный логин и пароль админа циски
серверами тоже прописана она

aaa authentication login default local group radius
aaa authentication ppp default if-needed local group radius
aaa authorization network default group radius
aaa accounting network default start-stop group radius
aaa session-id common
ip subnet-zero
ip cef
no ip dhcp conflict logging
!
isdn switch-type primary-net5
!
!
voice service voip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
sip
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
!
!
!
!
controller E1 3/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/1
framing NO-CRC4
pri-group timeslots 1-31
!
!
interface FastEthernet0/0
ip address 172.16.22.5 255.255.255.0
loopback
duplex full
speed 100
no cdp enable
!
interface FastEthernet0/1
ip address 172.16.2.5 255.255.255.0
loopback
duplex auto
speed auto
no cdp enable
!
interface Serial0/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
no cdp enable
!
interface Serial3/0:15
ip address 172.16.201.5 255.255.255.0
encapsulation ppp
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
peer default ip address pool setup_pool
ppp authentication chap pap
ppp multilink
!
interface Serial3/1:15
ip address 172.16.201.6 255.255.255.0
encapsulation ppp
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
peer default ip address pool setup_pool
ppp authentication chap pap
ppp multilink
!
interface Group-Async0
no ip address
no group-range
!
interface Group-Async1
ip unnumbered FastEthernet0/0
encapsulation ppp
ip tcp header-compression
async mode interactive
peer default ip address pool setup_pool
ppp authentication chap pap
group-range 1/00 1/59
!
ip classless
no ip http server
!
!
ip radius source-interface FastEthernet0/1
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
!
!
radius-server host 172.16.2.15 auth-port 1645 acct-port 1646
radius-server key **********
!
voice-port 3/0:D
!
voice-port 3/1:D
!
!
!
dial-peer voice 1 pots
incoming called-number 77
destination-pattern 3333333
direct-inward-dial
port 3/1:D
no register e164
!
dial-peer voice 3 voip
destination-pattern 3......
progress_ind setup enable 3
progress_ind alert enable 8
!
!
sip-ua
sip-server ipv4:172.16.22.5
!
!
Я бы выложил больше фрагментов сердца, Да не позволяет провайдер...
waxmax
новичок
 
Сообщения: 65
Зарегистрирован: 28 май 2009, 14:55

Re: cisco as5350 - dial-up и VoIP

Сообщение waxmax » 19 фев 2010, 11:20

вообщем все циска поддерживает, дело в версии IOS

вот теперь вопрос!
кто может поделица нужной иос, а именно какойнибудь Enterprise Services или Advanced Enterprise Services для as5350.

с названиями файлов помучился для as5350, так как с такими названиями типа cxxxx-adventerprisek9-mz или cxxxx-ipvoice-mz все понятно, а вот, например, c5350-js_ivs-mz.124-20.T понять куда мудренее.
расшифорвал кое что при помощи книг и сайтов, но все равно до конца не уверен в этих названиях. Что значит js_ivs или вообще jk9su2_ivs???
Я бы выложил больше фрагментов сердца, Да не позволяет провайдер...
waxmax
новичок
 
Сообщения: 65
Зарегистрирован: 28 май 2009, 14:55

Re: cisco as5350 - dial-up и VoIP

Сообщение root » 19 фев 2010, 17:06

для AS5300 у меня есть IOS`ы
Код: Выделить всё
 c5300-i-mz.123-17a.bin
c5300-is-mz.123-19.bin
c5300-j-mz.123-17a.bin
c5300-jk9s-mz.123-19.bin
c5300-js-mz.122-34.bin
c5300-js-mz.123-18.bin


для AS5350:
Код: Выделить всё
c5350-is-mz.124-3j.bin
c5350-js_ivs-mz.124-11.T1.bin
c5350-ik8s-mz.123-19.bin
c5350-ik9s-mz.124-7.bin
c5350-is-mz.123-17a.bin
c5350-is-mz.124-5a.bin
c5350-jk9s-mz.124-7.bin
c5350-jk9s-mz.124-7a.bin
c5350-js-mz.124-15.T10.bin


waxmax писал(а):Что значит js_ivs или вообще jk9su2_ivs???

м.б. тебе в этом поможет Cisco Feature Navigator -> http://tools.cisco.com/
С уважением, root

Изображение
------------
www.mega-net.ru - IT аутсорсинг
Аватара пользователя
root
Site Admin
 
Сообщения: 1882
Зарегистрирован: 11 июн 2008, 13:05
Откуда: Moscow, Russia

Re: cisco as5350 - dial-up и VoIP

Сообщение SHADOW » 01 мар 2012, 13:28

По подробней плиз как именно настроить дайлап доступ можешь ? :) или посоветуй чтонить для начинающего в этой фсере, азы CCNA знаю и сейчас буду пытаться настроить 5350 для доступа Дайлап а после и Воипа.
SHADOW
проходил мимо
 
Сообщения: 2
Зарегистрирован: 01 мар 2012, 13:25

Re: cisco as5350 - dial-up и VoIP

Сообщение TrEK » 02 мар 2012, 13:37

waxmax писал(а):обычный телефон в dlink dvg адаптер и в as5350 далее на АТС
одни говорят, что можно на циске регистировать, другие, что неприменно надо сервер отдельный.

можно рабочий конфиг посмареть, чтобы при простой схеме, как я описал, работал?
и заодно то что нужно соответственно прописать на sip адаптере.
иначе ятак и буду тупить :?
мне прост надо хоть чтото заработало из того что я имею, и отталкиваца от этого


Можно на Циске регистрировать, если еще акуален вопрос, я напишу.
TrEK
новичок
 
Сообщения: 44
Зарегистрирован: 02 мар 2012, 13:35

Re: cisco as5350 - dial-up и VoIP

Сообщение Dgoni_sp » 12 мар 2012, 03:32

SHADOW писал(а):По подробней плиз как именно настроить дайлап доступ можешь ? :) или посоветуй чтонить для начинающего в этой фсере, азы CCNA знаю и сейчас буду пытаться настроить 5350 для доступа Дайлап а после и Воипа.

Вопрос актуален ? готов помочь.
Dgoni_sp
новичок
 
Сообщения: 28
Зарегистрирован: 14 апр 2011, 13:59
Откуда: Северная столица

Пред.След.

Вернуться в Настройка VoIP железа

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron