ISP`s IT Аутсорсинг
Быстрый переход: Главная блога Главная сайта Форум
Если Вы чего то недопоняли или не нашли - задайте
вопрос на нашем форуме и мы попробуем Вам помочь.
Subnets.ru Регистрация IP и Автономных систем mega-net.ru

Вступление

Время от времени поднимается вопрос:

«А может ли Cisco выступать в качестве pptp-клиента?»

и, обычно, на него следует ответ: «Нет».

Однако, большинство IOS версий 12.2 или выше поддерживают это, если дана комманда service internal (она скрытая — по «?» не отображается, но работает) . После выполнения этой комманды в разделе vpdn group в секции request-dialin становятся доступны комманды rotary-group и pool-member.

Рабочая конфигурация на примере Cisco 827-V4 :

!
service internal
!

рекомендуется, подробности ниже — в «Ссылках»:
!
no ip gratuitous-arps
!
ip multicast-routing
!

Включаем VPN
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pptp
rotary-group 0

IP-адреса PPTP серверов:

initiate-to ip 1.1.1.1
initiate-to ip 2.2.2.2
!

Настройки Dialer0:
interface Dialer0

Уменьшение стандартного MTU:
mtu 1450

Получаем IP от PPTP сервера:
ip address negotiated

Источник сетевой активности, для автоустановления соединения, без использования дополнительных маршрутов:
ip pim dense-mode

Выставляем инкапсуляцию:
encapsulation ppp

Продолжаем настройку Dialer0:

dialer in-band
dialer idle-timeout 0
dialer string 123 ! Рекомендуется, но не используется
dialer vpdn
dialer-group 1
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe auto
ppp chap hostname ВАШ_ЛОГИН
ppp chap password 0 ВАШ_ПАРОЛЬ
!
dialer-list 1 protocol ip permit

Маршруты до PPTP-серверов:
ip route 1.1.1.1 255.255.255.255 Ethernet0
ip route 2.2.2.2 255.255.255.255 Ethernet0

Маршрут по умолчанию через VPN:
ip route 0.0.0.0 0.0.0.0 Dialer0

После применения данной конфигурации у вас должен сразу подняться туннель:

Router#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0                  192.168.221.106 YES DHCP   up                    up
Dialer0                    10.255.0.1      YES IPCP   up                    up
Virtual-Access1            unassigned      YES unset  up                    up

Подняться default роутинг:

Router#sh ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     1.1.1.0/32 is subnetted, 1 subnets
S       1.1.1.1 [1/0] via 192.168.221.1
     10.0.0.0/32 is subnetted, 2 subnets
C       10.30.10.1 is directly connected, Dialer0
C       10.255.0.1 is directly connected, Dialer0
C    192.168.221.0/24 is directly connected, Ethernet0
S*   0.0.0.0/0 is directly connected, Dialer0

Ссылки:

P.S. Все команды в вышеприведенной конфигурации являются обязательными.
P.P.S. При копировании статьи ссылка на источник ОБЯЗАТЕЛЬНА !
Автор: Панфилов Алексей (lehis (at) subnets.ru)

Похожие статьи:

    Не найдено

Прочитано: 17 536 раз(а)
Ничего не понялТак себе...Не плохоДовольно интересноОтлично ! То что нужно ! (голосов: 2, среднее: 5,00 из 5)
Загрузка...
Отправить на почту Отправить на почту

комментариев 8

  1. winterjamm сказал:

    «Источник сетевой активности, для автоустановления соединения, без использования дополнительных маршрутов:
    ip pim dense-mode»

    что значит источник сетевой активности? можно ли каким-то образом организовать автоустановку соединения без использования pim? В роутере кторый я собираюсь использовать для подключения (Cisco 851) в текущем IOS нет этой фичи, в других доступных иосах для нее тоже нет.

  2. dmitaur сказал:

    Скажите, такой момент: а если я не могу ввести команду ip pim dense-mode, что делать в этом случае?
    На команду выходит ошибка о несуществующем параметре pim.

  3. dmitaur сказал:

    Извиняюсь, у меня Cisco 871

  4. lehisnoe сказал:

    ip pim dense-mode нужна для организации исходящего трафика, заставляющего интерфейс Dialer0 устанавливать соединение.
    Как вариант, возможно попробовать прописать маршрут к какому-нибудь адресу через Dialer0, а затем послать icmp echo request на этот адрес.
    Второй вариант — заменить IOS на обладающий необходимым функционалом (например, c870-advipservicesk9-mz.124-4.XC2.bin) 🙂
    В случае с 851 с IOS’ами не густо, соотв, остается вариант с прописыванием роута к адресу и отправкой любого пакета на этот адрес.

    PS: для подбора IOS’а с нужными фичами рекомендую использовать Cisco Feature Navigator (ссылка на него есть тут — http://subnets.ru/wrapper.php?p=31 в разделе Cisco).

  5. dmitaur сказал:

    Спасибо за ответ!
    Пошел искать прошивку =)

  6. winterjamm сказал:

    Спасибо за ответ!

  7. dmitaur сказал:

    Такс, сделал все как указано, только вот не понятно:
    Маршруты до PPTP-серверов:
    ip route 1.1.1.1 255.255.255.255 Ethernet0
    ip route 2.2.2.2 255.255.255.255 Ethernet0
    Что это означает?
    Адреса городской сети я перенапрявляю со своего компа через циску на Fa4 (WAN), все остальные на Dialer0… для чего эти маршруты?
    И еще один момент — Диалер пытается запуститься, но выдает следующее: «%DIALER-4-MTU_WARNING: Current MTU setting of 1500 on Virtual-Access1 is being overwritten by setting of 1450 defined by Dialer0.», и, ничего не происходит.
    Прошу прощения за назойливость.
    Версию IOS использую c870-advipservicesk9-mz.124-4.XC4.bin.

  8. lehisnoe сказал:

    Для детальных разборов полетов добро пожаловать на наш форум (там сподручнее разбираться в вопросах) — http://subnets.ru/forum/ 😉

Добавить комментарий

Вам следует авторизоваться для размещения комментария.